solusi masalah unmet dependencies saat install paket di linux mint

saya adalah seorang newbie dalam dunia perlinuxan, jadi ceritanya kemarin (iya, beneran baru kemaren..serius deh 😀 ) saya install linux mint 13 (maya) dualboot dengan windows 7. Karena baru dalam fase “migrasi total ke linux” jadi sampai saat ini masih ada bayang-bayang windows meskipun saya menggunakan linux. Itu sebabnya saya coba buat menginstall paket wine agar bisa menjalankan aplikasi “under windows” dalam platform linux. Jadi sehari sebelumnya saya download paket wine secara manual dari apt-web nya ugm
maklumlah, karena saya berada di kondisi minim kuota internet dan lagi ga sempet cari wifi gratisan 😀
itu sebabnya saya pergi ke warnet buat download paket tersebut secara manual 😀

Entah karena ketidak telitian saya, dengan jumlah dependency paket yang bejibun yang ditampilkan untuk paket wine, jadinya tidak semua dependency paket terdownload (hihi, mungkin saya yang terlalu newbie sampai lupa kalau bisa menggunakan idm buat download semua link yang ada). Oke skip, setelah itu saya install manual paket tersebut (hasil downloadan dari apt-web nya ugm) dengan menggunakan perintah

$sudo dpkg -i *.deb

yah, karena adanya dependency paket yang tidak sempat terdownload tersebut, entah kenapa otak newbie saya terus berfikir “wah, ini mesti nanti bermasalah ini sama dependency paketnya…ribet deh kayakny”
berawal dari pikiran konyol tersebut, entah kenapa tangan saya langsung mengetikkan perintah

sudo dpkg -r wine1.3

dan

sudo dpkg -r winetricks

. Ke esokan harinya, ceritanya saya pergi ke kampus, untuk mengupdate sistem saya. Namun, keanehan terjadi ketika saya mencoba melakukan update dengan perintah

sudo apt-get update && sudo apt-get upgrade

ada informasi error yang kurang lebih seperti ini(banyak banget, liatin yang penting aja :D)

E:Sub-process /usr/bin/dpkg returned an error code (1) .

dan karena hal tersebut, saya tidak bisa melakukan instalasi paket apapun, tidak satupun paket dapat saya instal baik melalui software centernya maupun melalui command line 😦
Saya yang newbie ini tetap belagak tenang, saya kemudian coba menggunakan perintah sudo dpkg –configure -a eh malah keluarnya seperti ini

robofics robofics # dpkg --configure -a
dpkg: dependency problems prevent configuration of libpam-winbind:
 libpam-winbind depends on winbind (= 2:3.6.3-2ubuntu2.10); however:
  Version of winbind on system is 2:3.5.11~dfsg-1ubuntu2.1.
dpkg: error processing libpam-winbind (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of winbind:
 winbind depends on libwbclient0 (= 2:3.5.11~dfsg-1ubuntu2.1); however:
  Version of libwbclient0 on system is 2:3.6.3-2ubuntu2.10.
 winbind depends on samba-common (= 2:3.5.11~dfsg-1ubuntu2.1); however:
  Version of samba-common on system is 2:3.6.3-2ubuntu2.10.
 libpam-winbind (2:3.6.3-2ubuntu2.10) breaks winbind (<< 2:3.5.11~dfsg-3) and is unpacked but not configured.
  Version of winbind to be configured is 2:3.5.11~dfsg-1ubuntu2.1.
dpkg: error processing winbind (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ttf-mscorefonts-installer:
 ttf-mscorefonts-installer depends on defoma; however:
  Package defoma is not installed.
dpkg: error processing ttf-mscorefonts-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopenal1:
 libopenal-data (1:1.13-4ubuntu3) breaks libopenal1 (<= 1:1.13); however:
  Package libopenal1 is not configured yet.
dpkg: error processing wine1.4-i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.3:
 wine1.3 depends on libopenal1; however:
  Package libopenal1 is not configured yet.
 wine1.4-i386 (1.4-0ubuntu4.1) breaks wine1.3 (<< 1.4-0ubuntu1) and is unpacked but not configured.
  Version of wine1.3 to be configured is 1.3.28-0ubuntu1.
 wine1.4 (1.4-0ubuntu4.1) breaks wine1.3 (<< 1.4-0ubuntu1) and is unpacked but not configured.
  Version of wine1.3 to be configured is 1.3.28-0ubuntu1.
dpkg: error processing wine1.3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4:
 wine1.4 depends on wine1.4-i386 (= 1.4-0ubuntu4.1); however:
  Package wine1.4-i386 is not configured yet.
dpkg: error processing wine1.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhtml-form-perl:
 libhtml-form-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
dpkg: error processing libhtml-form-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhttp-message-perl:
 libhttp-message-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
dpkg: error processing libhttp-message-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhtml-tree-perl:
 libhtml-tree-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
dpkg: error processing libhtml-tree-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-common:
 wine1.4-common depends on wine1.4 (= 1.4-0ubuntu4.1); however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine1.4-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhttp-daemon-perl:
 libhttp-daemon-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-daemon-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblwp-protocol-https-perl:
 liblwp-protocol-https-perl depends on libio-socket-ssl-perl; however:
  Package libio-socket-ssl-perl is not configured yet.
dpkg: error processing liblwp-protocol-https-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwww-perl:
 libwww-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
 libwww-perl depends on libhtml-tree-perl; however:
  Package libhtml-tree-perl is not configured yet.
 libwww-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
 libwww-perl depends on liblwp-protocol-https-perl; however:
  Package liblwp-protocol-https-perl is not configured yet.
dpkg: error processing libwww-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhtml-format-perl:
 libhtml-format-perl depends on libhtml-tree-perl; however:
  Package libhtml-tree-perl is not configured yet.
dpkg: error processing libhtml-format-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhttp-negotiate-perl:
 libhttp-negotiate-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-negotiate-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icoutils:
 icoutils depends on libwww-perl; however:
  Package libwww-perl is not configured yet.
dpkg: error processing icoutils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhttp-cookies-perl:
 libhttp-cookies-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-cookies-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-exe-thumbnailer:
 gnome-exe-thumbnailer depends on icoutils; however:
  Package icoutils is not configured yet.
dpkg: error processing gnome-exe-thumbnailer (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libpam-winbind
 winbind
 ttf-mscorefonts-installer
 libopenal1
 libnet-ssleay-perl
 libio-socket-ssl-perl
 libhtml-parser-perl
 wine1.4-i386
 wine1.3
 wine1.4
 libhtml-form-perl
 libhttp-message-perl
 libhtml-tree-perl
 wine1.4-common
 libhttp-daemon-perl
 liblwp-protocol-https-perl
 libwww-perl
 libhtml-format-perl
 libhttp-negotiate-perl
 icoutils
 libhttp-cookies-perl
 gnome-exe-thumbnailer

nah, pas saya coba perintah

sudo apt-get -f install

berharap masalah dependency bisa diperbaiki, tetap saja tidak bisa..malah muncul seperti ini

robofics robofics # apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libhtml-parser-perl libnet-ssleay-perl libopenal1 ttf-mscorefonts-installer
  winbind wine1.3
Suggested packages:
  libdata-dump-perl
The following packages will be upgraded:
  libhtml-parser-perl libnet-ssleay-perl libopenal1 ttf-mscorefonts-installer
  winbind wine1.3
6 upgraded, 0 newly installed, 0 to remove and 703 not upgraded.
22 not fully installed or removed.
Need to get 0 B/4,827 kB of archives.
After this operation, 114 MB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of ttf-mscorefonts-installer:
 ttf-mscorefonts-installer depends on defoma; however:
  Package defoma is not installed.
dpkg: error processing ttf-mscorefonts-installer (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libopenal1:
 libopenal-data (1:1.13-4ubuntu3) breaks libopenal1 (<< 1:1.13-3) and is installed.
  Version of libopenal1 to be configured is 1:1.13-2.
dpkg: error processing libopenal1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of wine1.4-i386:
 wine1.4-i386 depends on libopenal1 (>= 1:1.13); however:
  Package libopenal1 is not configured yet.
dpkg: error processing wine1.4-i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of wine1.3:
 wine1.3 depends on libopenal1; however:
  Package libopenal1 is not configured yet.
 wine1.4-i386 (1.4-0ubuntu4.1) breaks wine1.3 (<< 1.4-0ubuntu1) and is unpacked but not configured.
  Version of wine1.3 to be configured is 1.3.28-0ubuntu1.
 wine1.4 (1.4-0ubuntu4.1) breaks wine1.3 (<< 1.4-0ubuntu1) and is unpacked but not configured.
  Version of wine1.3 to be configured is 1.3.28-0ubuntu1.
dpkg: error processing wine1.3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libnet-ssleay-perl:
 libnet-ssleay-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libnet-ssleay-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libio-socket-ssl-perl:
 libio-socket-ssl-perl depends on libnet-ssleay-perl; however:
  Package libnet-ssleay-perl is not configured yet.
dpkg: error processing libio-socket-ssl-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhtml-parser-perl:
 libhtml-parser-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libhtml-parser-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhtml-tree-perl:
 libhtml-tree-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
dpkg: error processing libhtml-tree-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhttp-message-perl:
 libhttp-message-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
dpkg: error processing libhttp-message-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhttp-cookies-perl:
 libhttp-cookies-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-cookies-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhttp-negotiate-perl:
 libhttp-negotiate-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-negotiate-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of liblwp-protocol-https-perl:
 liblwp-protocol-https-perl depends on libio-socket-ssl-perl; however:
  Package libio-socket-ssl-perl is not configured yet.
dpkg: error processing liblwp-protocol-https-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libwww-perl:
 libwww-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
 libwww-perl depends on libhtml-tree-perl; however:
  Package libhtml-tree-perl is not configured yet.
 libwww-perl depends on libhttp-cookies-perl; however:
  Package libhttp-cookies-perl is not configured yet.
 libwww-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
 libwww-perl depends on libhttp-negotiate-perl; however:
  Package libhttp-negotiate-perl is not configured yet.
 libwww-perl depends on liblwp-protocol-https-perl; however:
  Package liblwp-protocol-https-perl is not configured yet.
dpkg: error processing libwww-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhttp-daemon-perl:
 libhttp-daemon-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhttp-daemon-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhtml-form-perl:
 libhtml-form-perl depends on libhtml-parser-perl; however:
  Package libhtml-parser-perl is not configured yet.
 libhtml-form-perl depends on libhttp-message-perl; however:
  Package libhttp-message-perl is not configured yet.
dpkg: error processing libhtml-form-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of icoutils:
 icoutils depends on libwww-perl; however:
  Package libwww-perl is not configured yet.
dpkg: error processing icoutils (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libhtml-format-perl:
 libhtml-format-perl depends on libhtml-tree-perl; however:
  Package libhtml-tree-perl is not configured yet.
dpkg: error processing libhtml-format-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of winbind:
 winbind depends on libwbclient0 (= 2:3.5.11~dfsg-1ubuntu2.1); however:
  Version of libwbclient0 on system is 2:3.6.3-2ubuntu2.10.
 winbind depends on samba-common (= 2:3.5.11~dfsg-1ubuntu2.1); however:
  Version of samba-common on system is 2:3.6.3-2ubuntu2.10.
 libpam-winbind (2:3.6.3-2ubuntu2.10) breaks winbind (<< 2:3.5.11~dfsg-3) and is unpacked but not configured.
  Version of winbind to be configured is 2:3.5.11~dfsg-1ubuntu2.1.
dpkg: error processing winbind (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libpam-winbind:
 libpam-winbind depends on winbind (= 2:3.6.3-2ubuntu2.10); however:
  Version of winbind on system is 2:3.5.11~dfsg-1ubuntu2.1.
dpkg: error processing libpam-winbind (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-exe-thumbnailer:No apport report written because MaxReports is reached already

 gnome-exe-thumbnailer depends on icoutils; however:
  Package icoutils is not configured yet.
dpkg: error processing gnome-exe-thumbnailer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4:No apport report written because MaxReports is reached already

 wine1.4 depends on wine1.4-i386 (= 1.4-0ubuntu4.1); however:
  Package wine1.4-i386 is not configured yet.
dpkg: error processing wine1.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-common:No apport report written because MaxReports is reached already

 wine1.4-common depends on wine1.4 (= 1.4-0ubuntu4.1); however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine1.4-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 ttf-mscorefonts-installer
 libopenal1
 wine1.4-i386
 wine1.3
 libnet-ssleay-perl
 libio-socket-ssl-perl
 libhtml-parser-perl
 libhtml-tree-perl
 libhttp-message-perl
 libhttp-cookies-perl
 libhttp-negotiate-perl
 liblwp-protocol-https-perl
 libwww-perl
 libhttp-daemon-perl
 libhtml-form-perl
 icoutils
 libhtml-format-perl
 winbind
 libpam-winbind
 gnome-exe-thumbnailer
 wine1.4
 wine1.4-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

frustasi, saya coba googling, ada berbagai macam solusi disana, mulai dari perintah

sudo apt-get autoremove

sampe ke

sudo apt-get clean all lalu dilanjut dengan sudo apt-get -f install

tetap saja error itu muncul..bahkan di salah satu forum ada yang mengatakan bahwa direktori /boot telah penuh, solusinya hapus linux header yang tidak digunakan atau lakukan fresh install lagi 😀
dooh, rada tepok jidat juga saya baca posting di forum tersebut, padahal saya baru saja fresh install linux mint, masa iya direktori /boot nya udah penuh aja dan harus lakukan fresh install lagi, padahal belum di instal apapun kecuali wine kemaren 😀
Akhirnya saya mencoba bertanya di forum linux mint dengan melakukan posting disini
Namun, tetap saja errornya ga sembuh sembuh 😀
entah kenapa, kemudian saya mempunyai ide untuk mencoba mendownload paket yang error tersebut dengan perintah

sudo apt-get download libpam-winbind winbind ttf-mscorefonts-installer libopenal1 libnet-ssleay-perl libio-socket-ssl-perl libhtml-parser-perl wine1.4-i386 wine1.3 wine1.4 libhtml-form-perl libhttp-message-perl libhtml-tree-perl wine1.4-common libhttp-daemon-perl liblwp-protocol-https-perl libwww-perl libhtml-format-perl libhttp-negotiate-perl icoutils libhttp-cookies-perl gnome-exe-thumbnailer

kemudian saya melakukan installasi manual file tersebut dengan menggunakan perintah

sudo dpkg -i *.deb

dan taraaa, secara ajaib masalah saya teratasi..saya sudah bisa melakukan instalasi paket-paket linux mint sesuka hati saya 🙂

well, itu tadi sedikit pengetahuan sederhana, bagi newbie seperti saya, jika anda mengalami hal yang sama, harap diingat hal berikut ini

  • ingat hal apa yang anda lakukan sehingga terjadi error tersebut
  • akukan instalasi ulang paket yang membuat terjadinya error, saya sarankan instalasi secara manual
  • INGAT, JANGAN PERNAH MENGULANGI HAL (nomor 1) lagi 😀
  • Advertisements

    About robofics

    Adalah seorang yang masih terus berupaya mencari makna dari kehidupan. Penikmat sastra, seorang plegmatis. Seorang pembelajar dari universitas kehidupan.
    This entry was posted in linux and tagged , , , , , , . Bookmark the permalink.

    8 Responses to solusi masalah unmet dependencies saat install paket di linux mint

    1. Bismillahirrahmanirrahim.

      Pertama, sesulit apa pun permasalahan dependensi di Ubuntu (Mint saya anggap Ubuntu), itu masih jauh lebih mudah daripada permasalahan dependensi di Slackware dan Gentoo. Ini semestinya dipegang dulu baik-baik.

      Kedua, yang saya pahami dari kisah akang adalah sekadar ada paket-paket rantai yang belum terinstal. Ini mengesankan adanya error besar yang mengakibatkan si dpkg enggan menginstal paket lain. Solusinya sederhana sekali, instal saja dependensi rantai yang belum terinstal. Ingat, metode instalasi paket di Ubuntu adalah linear, bukan open ended.

      Ketiga, jika terjadi kembali kelak masalah seperti ini, kopi pastekan pesan error (E: blablabla) ke Gugel. Mungkin akang sudah tahu, tetapi saya hanya mengingatkan.

      Keempat, saya mencari blogger Linux seperti akang yang dengan santai bisa menulis kisah perjalanannya. Ini walau terkesan remeh temeh, tetapi akan berguna bagi orang lain. Karena ini dokumentasi. Terima kasih. Terima kasih.

      Kelima, saya mengundang akang untuk singgah di #ubuntu-indonesia. Silakan chatting di sana.

      Like

      • robofics says:

        suatu kehormatan akang berkenan memberikan pendapat akang yang luar biasa di blog sederhana saya ini kang.
        ya, benar memang permasalahan dependensi yang terjadi di ubuntu dan turunannya jauuh lebih mudah bila dibandingkan dengan slack / gentoo.
        hihi, maklum saya masih pemula kang untuk dunia perlinuxan, jadi yaa masih belum punya mental baja bila harus mendownload paket kemudian melakukan kompilasi secara manual.

        senang bisa berbagi kang, terimakasih, kapan2 saya mampir ke channel nya buat sekedar sharing

        Like

        • Halah, apalah omongan saya. Saya memandang perlu memberikan semangat kepada setiap blogger bagus yang tidak mendapat perhatian dari pengguna yang lain. Hal ini penting, saya rasa, untuk regenerasi komunitas kita. Maaf jika saya banyak membuat kesalahan.

          Like

        • robofics says:

          hehe, tapi saya menyadari bahwa pengalaman saya jauh berada di bawah akang untuk aspek per linux an..atau mungkin aspek lain yang belum saya ketahui heh.
          well, manusia itu kan jauh dari kesempurnaan kang, tak ada manusia yang sempurna, kesempurnaan itu sejatinya hanya milik Tuhan semesta alam kan hehe.
          Tapi yaa, dengan saling memaafkan itu lah salah satu cara luarbiasa untuk setidaknya, mendekati unsur sempurna itu

          Like

        • O, itu hanya masalah waktu. Saya tidak lain hanyalah penuntut ilmu kecil-kecilan.

          Like

        • robofics says:

          yes, poin yang saya dapatkan dari percakapan kita, entah ini mau akang terangkan secara eksplisit atau implisit. baik sadar maupun tidak, bahwa tidak ada orang yang pintar tanpa kebersediaan untuk belajar. Tak sepantasnya manusia itu bersombong diri atas apa yang ia miliki…

          Terimakasih kang, ilmu baru lagi tentang kehidupaan

          Like

        • Menarik. Saya tunggu akang di #ubuntu-indonesia.

          Like

        • robofics says:

          siap kang…

          Like

    Balas komentar

    Fill in your details below or click an icon to log in:

    WordPress.com Logo

    You are commenting using your WordPress.com account. Log Out / Change )

    Twitter picture

    You are commenting using your Twitter account. Log Out / Change )

    Facebook photo

    You are commenting using your Facebook account. Log Out / Change )

    Google+ photo

    You are commenting using your Google+ account. Log Out / Change )

    Connecting to %s